source: trunk/debian/rules @ 2628

Last change on this file since 2628 was 2628, checked in by Malte Marquarding, 12 years ago

restructure debian db build process

  • Property svn:executable set to *
File size: 647 bytes
RevLine 
[2166]1#!/usr/bin/make -f
2
[2620]3# Unset the environment variables set by dpkg-buildpackage. (This is
4# necessary because distutils is brittle with compiler/linker flags
5# set. Specifically, packages using f2py will break without this.)
6unexport CPPFLAGS
7unexport CFLAGS
8unexport CXXFLAGS
9unexport FFLAGS
10unexport LDFLAGS
[2166]11
[2620]12#exports specified using stdeb Setup-Env-Vars:
13#export DH_OPTIONS=--buildsystem=python_distutils
[2166]14
[2620]15override_dh_auto_install:
[2625]16        python setup.py install --root=debian/python-asap --install-layout=deb
[2166]17
[2620]18override_dh_auto_clean:
[2628]19        python setup.py clean
20        scons -c
[2166]21
[2620]22override_dh_auto_build:
[2628]23        python setup.py build_ext --casacoreroot=/usr
[2166]24
[2620]25%:
26        dh $@
Note: See TracBrowser for help on using the repository browser.