source: trunk/debian/rules @ 2625

Last change on this file since 2625 was 2625, checked in by Malte Marquarding, 12 years ago

Fix debian metadata

  • Property svn:executable set to *
File size: 614 bytes
Line 
1#!/usr/bin/make -f
2
3# Unset the environment variables set by dpkg-buildpackage. (This is
4# necessary because distutils is brittle with compiler/linker flags
5# set. Specifically, packages using f2py will break without this.)
6unexport CPPFLAGS
7unexport CFLAGS
8unexport CXXFLAGS
9unexport FFLAGS
10unexport LDFLAGS
11
12#exports specified using stdeb Setup-Env-Vars:
13#export DH_OPTIONS=--buildsystem=python_distutils
14
15override_dh_auto_install:
16        python setup.py build_ext --casacoreroot=/usr
17        python setup.py install --root=debian/python-asap --install-layout=deb
18
19override_dh_auto_clean:
20
21override_dh_auto_build:
22
23%:
24        dh $@
Note: See TracBrowser for help on using the repository browser.