source: trunk/debian/rules@ 3141

Last change on this file since 3141 was 3141, checked in by VincentMcIntyre, 6 years ago

Remove config.log in cleanup

  • Property svn:executable set to *
File size: 665 bytes
Line 
1#!/usr/bin/make -f
2
3# Unset the environment variables set by dpkg-buildpackage. (This is
4# necessary because distutils is brittle with compiler/linker flags
5# set. Specifically, packages using f2py will break without this.)
6unexport CPPFLAGS
7unexport CFLAGS
8unexport CXXFLAGS
9unexport FFLAGS
10unexport LDFLAGS
11
12#exports specified using stdeb Setup-Env-Vars:
13#export DH_OPTIONS=--buildsystem=python_distutils
14
15override_dh_auto_install:
16 python setup.py install --root=debian/python-asap --install-layout=deb
17
18override_dh_auto_clean:
19 python setup.py clean
20 scons -c
21 rm -f config.log
22
23override_dh_auto_build:
24 python setup.py build_ext --casacoreroot=/usr
25
26%:
27 dh $@
Note: See TracBrowser for help on using the repository browser.