Changeset 2620 for trunk/debian/rules


Ignore:
Timestamp:
08/06/12 12:13:54 (12 years ago)
Author:
Malte Marquarding
Message:

fix debian meta-data

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/debian/rules

    r2166 r2620  
    11#!/usr/bin/make -f
    22
    3 DEB_PYTHON_SYSTEM = pysupport
     3# Unset the environment variables set by dpkg-buildpackage. (This is
     4# necessary because distutils is brittle with compiler/linker flags
     5# set. Specifically, packages using f2py will break without this.)
     6unexport CPPFLAGS
     7unexport CFLAGS
     8unexport CXXFLAGS
     9unexport FFLAGS
     10unexport LDFLAGS
    411
    5 include /usr/share/cdbs/1/rules/buildcore.mk
    6 include /usr/share/cdbs/1/rules/debhelper.mk
    7 include /usr/share/cdbs/1/class/python-distutils.mk
    8 #include /usr/share/cdbs/1/rules/simple-patchsys.mk
     12#exports specified using stdeb Setup-Env-Vars:
     13#export DH_OPTIONS=--buildsystem=python_distutils
    914
    10 DEB_PYTHON_INSTALL_ARGS_ALL += --single-version-externally-managed --install-lib usr/share/python-support/asap
     15override_dh_auto_install:
     16        python setup.py install --root=debian/asap --install-layout=deb
    1117
    12 binary-post-install/asap::
    13 #       -rm -rf debian/asap/usr/lib/
     18override_dh_auto_clean:
    1419
     20override_dh_auto_build:
    1521
    16 clean::
    17         -rm -rf asap.egg-info
     22%:
     23        dh $@
Note: See TracChangeset for help on using the changeset viewer.