Changeset 2620 for trunk/debian/rules
- Timestamp:
- 08/06/12 12:13:54 (12 years ago)
- File:
-
- 1 edited
Legend:
- Unmodified
- Added
- Removed
-
trunk/debian/rules
r2166 r2620 1 1 #!/usr/bin/make -f 2 2 3 DEB_PYTHON_SYSTEM = pysupport 3 # Unset the environment variables set by dpkg-buildpackage. (This is 4 # necessary because distutils is brittle with compiler/linker flags 5 # set. Specifically, packages using f2py will break without this.) 6 unexport CPPFLAGS 7 unexport CFLAGS 8 unexport CXXFLAGS 9 unexport FFLAGS 10 unexport LDFLAGS 4 11 5 include /usr/share/cdbs/1/rules/buildcore.mk 6 include /usr/share/cdbs/1/rules/debhelper.mk 7 include /usr/share/cdbs/1/class/python-distutils.mk 8 #include /usr/share/cdbs/1/rules/simple-patchsys.mk 12 #exports specified using stdeb Setup-Env-Vars: 13 #export DH_OPTIONS=--buildsystem=python_distutils 9 14 10 DEB_PYTHON_INSTALL_ARGS_ALL += --single-version-externally-managed --install-lib usr/share/python-support/asap 15 override_dh_auto_install: 16 python setup.py install --root=debian/asap --install-layout=deb 11 17 12 binary-post-install/asap:: 13 # -rm -rf debian/asap/usr/lib/ 18 override_dh_auto_clean: 14 19 20 override_dh_auto_build: 15 21 16 clean::17 -rm -rf asap.egg-info22 %: 23 dh $@
Note:
See TracChangeset
for help on using the changeset viewer.