Last change
on this file since 2623 was 2620, checked in by Malte Marquarding, 12 years ago |
fix debian meta-data
|
-
Property svn:executable
set to
*
|
File size:
560 bytes
|
Line | |
---|
1 | #!/usr/bin/make -f
|
---|
2 |
|
---|
3 | # Unset the environment variables set by dpkg-buildpackage. (This is
|
---|
4 | # necessary because distutils is brittle with compiler/linker flags
|
---|
5 | # set. Specifically, packages using f2py will break without this.)
|
---|
6 | unexport CPPFLAGS
|
---|
7 | unexport CFLAGS
|
---|
8 | unexport CXXFLAGS
|
---|
9 | unexport FFLAGS
|
---|
10 | unexport LDFLAGS
|
---|
11 |
|
---|
12 | #exports specified using stdeb Setup-Env-Vars:
|
---|
13 | #export DH_OPTIONS=--buildsystem=python_distutils
|
---|
14 |
|
---|
15 | override_dh_auto_install:
|
---|
16 | python setup.py install --root=debian/asap --install-layout=deb
|
---|
17 |
|
---|
18 | override_dh_auto_clean:
|
---|
19 |
|
---|
20 | override_dh_auto_build:
|
---|
21 |
|
---|
22 | %:
|
---|
23 | dh $@
|
---|
Note:
See
TracBrowser
for help on using the repository browser.