source: trunk/debian/rules

Last change on this file was 3144, checked in by VincentMcIntyre, 5 years ago

Remove egg-info dir when cleaning up

  • Property svn:executable set to *
File size: 687 bytes
RevLine 
[2166]1#!/usr/bin/make -f
2
[2620]3# Unset the environment variables set by dpkg-buildpackage. (This is
4# necessary because distutils is brittle with compiler/linker flags
5# set. Specifically, packages using f2py will break without this.)
6unexport CPPFLAGS
7unexport CFLAGS
8unexport CXXFLAGS
9unexport FFLAGS
10unexport LDFLAGS
[2166]11
[2620]12#exports specified using stdeb Setup-Env-Vars:
13#export DH_OPTIONS=--buildsystem=python_distutils
[2166]14
[2620]15override_dh_auto_install:
[2625]16        python setup.py install --root=debian/python-asap --install-layout=deb
[2166]17
[2620]18override_dh_auto_clean:
[2628]19        python setup.py clean
20        scons -c
[3141]21        rm -f config.log
[3144]22        rm -rf asap.egg-info
[2166]23
[2620]24override_dh_auto_build:
[2628]25        python setup.py build_ext --casacoreroot=/usr
[2166]26
[2620]27%:
28        dh $@
Note: See TracBrowser for help on using the repository browser.